Author Topic: Key West just quit running  (Read 653 times)

Cheveyo

  • Guest
Key West just quit running
« on: September 19, 2016, 01:39:47 PM »
I was riding the other day and the scooter was running great and suddenly it just died like the kill switch was turned off. Now it won't start. It has good strong spark and the plug looks good but the spark is yellow not blue. Would I still have spark if the CDI was going bad? Could it be a bad coil? Won't even start with starter spray and its getting gas. I don't have a compression gauge but it blows my finger off the sparkplug hole with the electric start. I don't see any leaks around the head gasket. Only things I've seen is a very little grimy oil in the CVT right below the variator. Could it be a blown crankseal? Would I still have compression in the head if it was the crankseal? Would the seal blowing cause it to die suddenly like that? Also it seems too easy to move the kick start by hand. It is a 2007 with 4000 miles that had been sitting not being used when I bought it. I'm thinking I should just replace the seals gaskets and rings. Does that sound right for the symptoms? Just trying to narrow it down before buying stuff it doesn't need.

harry

  • Administrator
  • Hero Member
  • *****
  • Posts: 828
  • Personal scooter consultant to the rich & famous
    • Whidbey Island Moped
Re: Key West just quit running
« Reply #1 on: September 19, 2016, 05:17:20 PM »
how new is the plug? what cdi ? stock or after market? everything else stock?
also check the plug cap is connected firmly to the wire.
blowing your  finger off  is around 100-110psi you should have 120-140psi

cracking the case is not something you want to do.
if you were spewing oil and getting the weights or variator covered w/oil
then yeah replace them..

oilyhans


i own a scooter shop  with rentals ,sales& racing parts.
i also appraise scooters for KBB.

2003 Vino classic stage 0.75
de-reged stock variator w/8g sliding weights.
1.5k rpm  springs
42mph
2005 veniceLX ~70cc~upjet~1.5k rpm springs & 7gr sliders
46mph
KeyWest de restricted~8gr slide

Cheveyo

  • Guest
Re: Key West just quit running
« Reply #2 on: September 21, 2016, 11:38:52 AM »
You know I haven't changed the plug because the old one looked good but I'm going to feel pretty stupid if it just needs a new plug! I will try that and I'm borrowing a compression tester and a multimeter to check the cdi too. The cdi is an aftermarket unlimited rev. Should have more info in a few days. I will post the results. It might help someone else. Thanks oilyhans!

Cheveyo

  • Guest
Re: Key West just quit running
« Reply #3 on: September 22, 2016, 03:20:03 PM »
Well put in a new plug and nothing. Checked the compression and 60psi. No wonder it won't start! Off with the head!

harry

  • Administrator
  • Hero Member
  • *****
  • Posts: 828
  • Personal scooter consultant to the rich & famous
    • Whidbey Island Moped
Re: Key West just quit running
« Reply #4 on: September 22, 2016, 04:57:09 PM »
look at the electrode of the old plug and if you  see tiny balls
stuck to it  if so its part of your piston  :-\

oilyhans
i own a scooter shop  with rentals ,sales& racing parts.
i also appraise scooters for KBB.

2003 Vino classic stage 0.75
de-reged stock variator w/8g sliding weights.
1.5k rpm  springs
42mph
2005 veniceLX ~70cc~upjet~1.5k rpm springs & 7gr sliders
46mph
KeyWest de restricted~8gr slide

Cheveyo

  • Guest
Re: Key West just quit running
« Reply #5 on: September 22, 2016, 07:18:40 PM »
No the plug looked good. Nice light brown. I'm taking the top end off tomorrow though so we'll see.

Koreydubyah

  • Newbie
  • *
  • Posts: 15
Re: Key West just quit running
« Reply #6 on: May 18, 2017, 12:10:12 PM »
I have same problem. I'm getting a compression tester today and testing it.

Spark - good
Gas - yes